Slitherine Service Status
All Incidents Login
OS update (#12)
Started: 04/26/2023 16:52 UTC

There will be an OS update performed on the server powering Slitherine Same Login. The update will be non-interruptive.

Slitherine Same Login

MAINTENANCE

STATUS RESOLVED

Update - 04/27/2023 01:37 UTC

The update sucessfully completed.

Update - 04/27/2023 01:30 UTC

Updating the OS.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.