Slitherine Service Status
All Incidents Login
Website update (#13)
Started: 04/27/2023 16:00 UTC
Expected ending: 04/27/2023 17:00 UTC

There will be the website software update. The update involves a database migration that will cause the webiste being unavailable for a brief period of time.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 04/27/2023 16:56 UTC

The update is completed.

Update - 04/27/2023 16:04 UTC

The update is in progress.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.