Slitherine Service Status
All Incidents Login
OS update. (#14)
Started: 04/28/2023 15:21 UTC

Need to performing an emergency OS update. This may cause a bried downtime.

PBEM

MAINTENANCE

STATUS RESOLVED

Update - 04/28/2023 16:21 UTC

The update is completed.

Update - 04/28/2023 15:23 UTC

The OS update is in progress.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.