Slitherine Service Status
All Incidents Login
Intermittent problem (#15)
Started: 04/30/2023 16:46 UTC

Our hosting experiencing a DDOS attack therefore our websites can be intermittently down. Sorry for the inconvenience.

Slitherine website
MatrixGames website
Slitherine website
MatrixGames website
Slitherine website
MatrixGames website
PBEM
Slitherine forum
Slitherine forum
Slitherine forum

MAINTENANCE

STATUS RESOLVED

Update - 04/30/2023 18:30 UTC

The issue has been resolved.

Update - 04/30/2023 16:52 UTC

We will keep you updated.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.