Slitherine Service Status
All Incidents Login
Database corruption repair (#17)
Started: 05/02/2023 16:04 UTC

The database got corrupted on the server. We will try to repair it. Thanks you for your patience.

PBEM

MAJOR OUTAGE

STATUS RESOLVED

Update - 05/03/2023 04:14 UTC

The database has been fixed. The PBEM service is operational.

Update - 05/02/2023 16:08 UTC

The work is in progress.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.