Slitherine Service Status
All Incidents Login
Minor website update (#18)
Started: 05/04/2023 15:45 UTC

Minor website update will be performed shortly. This should not cause a downtime. Cache will be cleared that will cause a log out for logged in users.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 05/04/2023 16:02 UTC

The update sucessfully completed.

Update - 05/04/2023 15:55 UTC

Performing the update now.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.