Slitherine Service Status
All Incidents Login
Minor website software update (#23)
Started: 05/23/2023 20:12 UTC

We are going to push a minor website software update. There should be no downtime but could be intermittent connection issues.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 05/23/2023 20:20 UTC

The update is complete.

Update - 05/23/2023 20:16 UTC

Started the update.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.