Slitherine Service Status
All Incidents Login
The website update (#24)
Started: 06/01/2023 16:17 UTC

The website will be updated with minor updates shortly. There should be no downtime.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 06/01/2023 17:24 UTC

The website is sucessfully updated.

Update - 06/01/2023 16:22 UTC

The update is on the way.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.