Slitherine Service Status
All Incidents Login
Website update (#29)
Started: 06/15/2023 19:00 UTC
Expected ending: 06/15/2023 20:00 UTC

The website update will be performed. There may be intermittent brief access interruptions.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 06/15/2023 19:53 UTC

The website has been sucessfully updated.

Update - 06/15/2023 19:43 UTC

The update is in progress.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.