Slitherine Service Status
All Incidents Login
Website update (#34)
Started: 08/29/2023 22:00 UTC
Expected ending: 08/29/2023 23:00 UTC

We are going to perform the website software update. It should be done within an hour. There should be no downtime.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 08/30/2023 01:28 UTC

The maintenance is sucessfully completed.

Update - 08/29/2023 22:36 UTC

Pushing updates now.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.