Slitherine Service Status
All Incidents Login
Website update (#35)
Started: 09/07/2023 20:00 UTC
Expected ending: 09/07/2023 21:00 UTC

We are going to perform websites update today at 8pm EDT. This may involve a few minutes downtime.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 09/08/2023 03:39 UTC

The update is completed sucessfully.

Update - 09/08/2023 00:39 UTC

Updating the website now.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.