Slitherine Service Status
All Incidents Login
Website maintenance (#36)
Started: 09/13/2023 16:35 UTC
Expected ending: 09/13/2023 16:45 UTC

The website will be updated. If everything goes normal it should not cause a downtime.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 09/13/2023 16:39 UTC

The update is sucessfully completed.

Update - 09/13/2023 16:35 UTC

The update is underway.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.