Slitherine Service Status
All Incidents Login
Websites update (#37)
Started: 09/21/2023 18:00 UTC
Expected ending: 09/21/2023 19:00 UTC

We are going to perform website update today at 2pm EDT. If everything goes OK there should be no downtime.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 09/21/2023 18:42 UTC

The update is completed sucessfully.

Update - 09/21/2023 18:08 UTC

The update is on the way.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.