Slitherine Service Status
All Incidents Login
PBEM login issue (#38)
Started: 10/24/2023 16:48 UTC

There is a problem introduced in the latest update pushed to the Slitherine Same Login system that prevents users from login in to PBEM.

Slitherine Same Login

CRITICAL OUTAGE

STATUS RESOLVED

Update - 10/24/2023 17:09 UTC

The issue is fixed.

Update - 10/24/2023 16:53 UTC

The prblem is being worked on, it should be fixed shortly.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.