Slitherine Service Status
All Incidents Login
Updates to the payment system (#41)
Started: 01/29/2024 13:00 UTC
Expected ending: 01/29/2024 15:00 UTC

We are going to test updates to the payment system. The test window is 2 hours, from 1pm to 3pm UK time. There should be no distruction to the work of the website.

Slitherine website
MatrixGames website

MAINTENANCE

STATUS RESOLVED

Update - 02/02/2024 18:55 UTC

The test completed sucessfully.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.