Slitherine Service Status
All Incidents Login
Software upgrade (#55)
Started: 06/04/2025 02:00 UTC
Expected ending: 06/04/2025 03:00 UTC

We are going to upgrade the forum software to the latest version. The downtime should be around 10 minutes within the maintenance window. Thank you for your patience.

MatrixGames forum

MAINTENANCE

STATUS RESOLVED

Update - 06/04/2025 02:39 UTC

The upgrade is completed.

Update - 06/04/2025 02:02 UTC

The upgrade is in progress.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.