Slitherine Service Status
All Incidents Login
Software upgrade (#65)
Started: 06/21/2026 03:00 UTC
Expected ending: 06/21/2026 16:00 UTC

We are going to upgrade forum software to the latest version. The forum will be unavaibale during the maintenance. Thank you for your patience.

MatrixGames forum

MAINTENANCE

STATUS RESOLVED

Update - 06/21/2026 04:53 UTC

The upgrade sucessfully completed.

Update - 06/21/2026 03:08 UTC

The maintenance is in progress.

Copyright © 2026, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.