Slitherine Service Status
All Incidents Login
Forum extension update (#28)
Started: 06/14/2023 16:31 UTC

There will be forum software update involving one of its extenssions. There should be no downtime.

MatrixGames forum

MAINTENANCE

STATUS RESOLVED

Update - 06/14/2023 16:38 UTC

Sucessfully updated.

Update - 06/14/2023 16:34 UTC

Being worked on now.

Copyright © 2025, Slitherine Software UK Ltd., Trade Marks belong to their respective Owners. All Rights Reserved.